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1. Document Creation 
 

1.1. Introduction 

As of Yutraffic Office 8.1, a documentation printout for Microsoft Word (*.docx) 
is available in addition to the familiar MDoku documentation printout (*.pdf). 
Docx printing covers all planning data and has been continuously expanded to 
include supply data since Office 8.6. This document provides a brief 
introduction to Docx documentation printing and is intended to enable flexible 
and efficient use of the functionality. YouTube tutorials are also available. 

This description was created for Microsoft® Word for Microsoft 365 MSO 
(Version 2309 Build 16.0.16827.20278) and Yutraffic Office 8.7. 

 

1.2. Step-by-step instructions 

Selecting the menu item “Print” in the main window starts a wizard that guides 
you through the document creation process. 
 

                

Fig. 1: Menu item for starting Docx printing in the Office main window. The menu item is visible in the 
“Intersection planning” and “Intersection configuration” perspectives. 

Step 1: Starting the Print-Wizard 

The start page of the print wizard offers the option of displaying the current 
manual for Docx documentation printing and a short introductory video. 

                          

Fig. 2: The start page of the print wizard offers two options                                                                         
to obtain more detailed information on using the print function. 
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Step 2: Select template and document name 

The second step is to define the print template used for document creation 
and the name of the document to be created:   

                   

Fig. 3: Print dialog for selecting the template and the document. 

 

Two standard templates are delivered with the Office installation. These are 
located under C:\Sitraffic\Office\SystemTemplates and support the following 
two use cases: 
 

• Documentation printing: Template_OfficeDocu_EN.docx    

• Editor preview print: Template_OfficeDocu_Editor_EN.docx   
 
In general, the print templates are used to customize the documentation while 
at the same time reducing the effort required for manual reworking. See 
chapter 2 for details. 
 
Please note: If one of the two files (template or documentation) has already 
been opened by another program, this is displayed as an error with a red 
cross on the user interface. 

 

Step 3: Selecting the objects to be printed  

In the third step, the objects to be printed (e.g. signal programs or the annual 
automatic) and the desired object instances (e.g. SP 1 and 3) are defined. 
The selection and sequence of objects can be defined using the templates. 
See chapter 2.1 for details.   

           

Fig. 4: Print dialog for selecting objects and their instances. Only the selected instances of an object are printed.  
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Step 4: Customizing the fields to be printed 

In the fourth step, the fields to be printed (e.g. node name, Znr, Fnr) can be 
customized. If no adjustments are made, the values are taken unchanged 
from the properties of the node version for which the documentation is to be 
created. 

     

Fig. 5: Print dialog for adjusting the fields with the intersection properties. Without manual adjustments, the 
data is taken directly from the properties of the intersection version. 

  

Fields in Microsoft Word are variables that can be described by the user. They 
are used within the print templates and serve to individualize the 
documentation. See chapter 2.4 for details.      

  

Step 5: Printing options 

In the fifth step, the output format of the documentation can be selected. The 
formats *.docx and *.pdf are currently supported. You can also select whether 
the documentation should be opened automatically once it has been 
generated. 

       

       

                        Fig. 6: Print dialog with various options for document creation and automatic opening of the document.  
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Please note: Regardless of the selected option for the output format, a *.docx 
document is always created. Optionally, Office can generate a *.pdf directly 
from this in a subsequent step. In both cases, adjustments to the content and 
form of the documentation are made in the *.docx format template. 

Please note: The *.pdf generation does not require Microsoft Word. However, 
the fonts used in the document template should also be available on the 
operating system used. Otherwise there will be differences between the 
document template and the generated documentation. 

 

 

 

Step 6: Starting the printout 
  
In the sixth and final step, the generation of the document is started. By going 
back to the previous steps, settings made so far can be adjusted again here. 
 
Please note: Depending on the selected scope and the options used, 
generation may take several minutes. The progress is displayed in a separate 
dialog. 
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2. Customizing the Print Template 
The standard print templates supplied with Yutraffic Office can be found under 
C:\Sitraffic\Office\SystemTemplates and are used to customize the 
documentation. There is one template each for German and English for 
documentation and preview printing: 

• Documentation print: Template_OfficeDocu_EN.docx    

• Editor preview print: Template_OfficeDocu_Editor_EN.docx 
   

2.1. Selection and sequence 
The templates contain special print markings. These are used to define the 
selection and sequence of the objects to be printed.   

         

Fig. 7: The illustration on the left shows an example of the print markings of the individual objects in the template 
(outline view). The right-hand side shows the corresponding object selection in the print dialog. 

 

The standard template contains 28 print markers (e.g. {SitrafficOffice: 
StageDefinition.}). Each marker corresponds to a printable object (see chapter 
4.1). In step 2 of the print dialog (see chapter 1), only those objects appear for 
which there are also markings in the template. The order of the objects 
displayed in the dialog corresponds to the order of the markings in the 
template. This sequence is then also found in the finished printout.  

Depending on the object, there may be an associated list of instances (e.g. 
phase transitions). Their sequence is defined as usual in the respective editor. 
The instances required for the documentation can then be selected in the print 
dialog. The easiest way to edit the print marks is in the “Outline” view. You can 
then switch back to the usual view via “Print layout”. 
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                Fig. 8: Microsoft Word main window for switching between outline view and print layout. 

  

 

For example, standard templates can be created for various applications such 
as planning or device documentation. The template then only contains the 
print markings for the desired objects (see also 4.4.5). 
 

2.2. Page layout 

Depending on the type of objects, it makes sense to adjust the orientation of 
the pages (e.g. landscape format for site plans or portrait format for the signal 
group list). To do this, please select a section in the “Outline” view and then 
make the appropriate adjustment via Layout->Alignment.  

 

Fig. 9: Microsoft Word main window for setting the page layout. 

  

Please note: The horizontal scaling of the signal programs is printed 
depending on the available width of the page. That scaling can’t be changed 
by subsequently changing the page layout. Therefore, when changing from 
landscape to portrait format, please ensure that the entire duration of the 
signal program is still visible.     

 
 

2.3. Page breaks 

The page layout settings are always applied to all pages of the same section. 
In order to have different page layouts for different sections (e.g. signal 
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programs in landscape format, matrices in portrait format), it can be useful to 
insert breaks: Layout-> Breaks 

 

               

Fig. 10: Microsoft Word main window for inserting page breaks or sections. The page layout can be selected 
separately for each section. 

  

2.4. Table properties 

Each object is assigned an unchangeable table type (e.g. sitraffic matrix for 
IT- or OT matrices). The table type defines various properties, such as the 
font and font size for displaying the respective entries or the line width for 
displaying the table itself. 
 

 

Fig. 11: Microsoft Word main window for customizing the table styles. 

 
To change the properties for a table type, first delete the type and then create 
a new one with the desired properties. Alternatively, the table properties can 
also be adjusted in the finished document. It is also somewhat easier to 
change the table properties in the generated document (see section 3.2).  
Please note: The name of the newly created table type must correspond 
exactly to one of the predefined identifiers. An overview of the table types and 
the corresponding objects can be found in chapter 4.2. 
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2.5. Use of fields 

By using the so-called fields, various values, such as the short name of the 
intersection IntersectionShortName, can be automatically included and 
updated in the documentation. For this purpose, the fields are placed at the 
desired positions in the template and made visible with the ALT + F9 key 
combination for easier recognition.  

 

Fig. 12: Display of fields in MS Word documents (ALT + F9).  

A selection of the most common fields can be found in the standard template 
in the “General” chapter. All fields supported in the template are available for 
selection via Insert -> Quick modules -> Field -> DocProperty (see chapter 
4.3). 

To transfer the specific value of a field to the document to be created, the field 
must be updated. This is possible in three ways. 

 

2.5.1. Manual update 

For manual updating, fields can be selected and updated by pressing F9. This 
function can also be called up via the context menu (right mouse button) -> 
“Update fields”. 

 

2.5.2. Auto update 

As an alternative to manual updating, automatic updating can be used during 
document generation (see Fig. 13 on the right):                                                                
File -> Options ->Display -> “Update fields before printing”                                             
The automatic update offers the advantage that the headers and footers in 
particular are also covered.     

        

Fig. 13: Microsoft Word main window for customizing the table styles. 
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2.5.3. Print again 

If the fields are to be updated without generating a document, it is sufficient to 
select the page preview for the printout (see Fig. 13 left). All fields in the 
document are updated in this way even without printing the documentation 
(shortcut Ctrl + P). 

 

2.6. Header/footer and page number 

Headers and footers can be customized via Insert -> Header and Footer. 
Fields with additional information about the document (e.g. Name of 
intersection or Fnr) can be inserted within the headers and footers, for 
example. The display of the page number can also be defined in this view. 

 

 

Fig. 14: Microsoft Word main window for creating headers/footers and inserting the page number. 
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3. Customizing the Documentation 
 

 
In some cases, it is easier to make adjustments directly in the finished 
document. This is particularly the case when an existing document needs to 
be updated with new data (e.g. additional or modified signal programs). 

 

3.1. Update of objects 

After printing, there are two ways to update the objects. 
 

3.1.1. Printing again 

At the end of the printing process, all print marks are automatically removed 
from the finished document. If the documentation for an object, e.g. for certain 
instances of phase transitions, is to be updated subsequently, please proceed 
as follows: 

• remove the old printout of the respective object from the existing 
documentation 

• insert the corresponding marker (e.g. {SitrafficOffice: 
StageTransitionInstances}) into the documentation - see chapter 4.1 

• Define the modified document as a template in the print dialog and then 
generate the documentation updated with the new objects. 
 

3.1.2. Printing a separate document 

As an alternative to inserting a print marker and reprinting, the objects to be 
updated can be printed in a separate document. This is possible, for example, 
via the page preview print in the respective editor. From there, the updated 
objects can be inserted into the documentation via copy & paste. 

 

3.2. Updating of fields 
After printing, there are two ways to update the fields. Updating means setting 
the value of a field again based on the data of the node version (e.g. 
IntersectionDescription). 
 

3.2.1. Printing again 

When printing the document again, the values of the fields can also be reset 
manually at the same time (see chapter 1, step 3). It is important that at least 
one object has also been selected for updating. 
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3.2.2. Setting the field value again 

The value of a field can also be changed directly in the created document. To 
do this, please call up the following dialog from the main window via                        
File->Information: 

 

Fig. 15: Dialog to open the extended document properties. 

  

The window that then opens offers a selection of the available fields with the 
currently set value under “Customize”. 

             

Fig. 16: Dialog for setting the field values in a document. 

  

To apply the new value set here to the entire document, please proceed as 
described in section 2.5. 
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3.3. Tables 

Tables can be customized individually or collectively for the individual table 
types. Regardless of the desired changes, the table must first be selected. To 
do this, please click in the top left-hand corner: 
 

 

Fig. 17: Selection of a table in a Word document. 

  

3.3.1. Customizing individual tables 

The column width can be adjusted via the context menu. The most common 
options are “Auto fit to content” or “Fit size to window”. 
 

 

Fig. 18: Options for automatic formatting of tables in the Word document. 

  

3.3.2. Customizing the table format 

The format can also be adjusted for all tables of the same type at the same 
time. The table type (e.g. Sitraffic-Table) is selected in the Word header by 
double-clicking on the edge of the table. The properties of the type can then 
be changed via the context menu.  

                           

Fig. 19.: Microsoft Word main window for adjusting the table format in the document.  
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4. Appendix 
 

4.1. Print markings 

This overview shows the available print markers.  

 . 

Name of marker Object Office Version 

{SitrafficOffice: Description} User data from 8.1 

{SitrafficOffice: ConflictingPlan} Layout plan from 8.1 

{SitrafficOffice: VolumeFlowInstances} Volume flows from 8.1 

{SitrafficOffice: SignalgroupInstances} Signal group list from 8.1 

{SitrafficOffice: SignalgroupHeadInstances}  Signal heads from 8.1 

  

{SitrafficOffice: DemandInstances} Detectors from 8.1 

{SitrafficOffice: DetectorExtendedInstances} Extended detector parameters from 8.7 

{SitrafficOffice: RequestInstances} Request instances from 8.1 

{SitrafficOffice: ExtensionInstances} Extension instances from 8.1 

  

{SitrafficOffice: ReportingPointInstances} Reporting point list from 8.7 

{SitrafficOffice: PublicTransportInstances} PT directions from 8.1 

  

{SitrafficOffice: IntergreentimeCalculationInstances} Integreen time calculation from 8.1 

{SitrafficOffice: Matrices} IT- and OT matrices from 8.3 

  

{SitrafficOffice: SignalPrograms} Signal programs from 8.6 

{SitrafficOffice: HBS2015CapacityAnalysis} HBS 2015 from 8.1 

{SitrafficOffice: AnnualAutomaticInstances} Annual automatic (JAUT) from 8.1 

  

{SitrafficOffice: StageDefinition} Stage definition from 8.2 

{SitrafficOffice: StageTransitionInstances} Stage transitions from 8.5 

{SitrafficOffice: FramePlanOverview} Stage frame plans - Overview from 8.1 

{SitrafficOffice: FramePlanInstances} Stage frame plans from 8.1 

  

{SitrafficOffice: SlLogic} SL Demand-/extension conditions from 8.2 

{SitrafficOffice: SlStageData} SL Stage data from 8.2 

   

{SitrafficOffice: PDMParameter} TL User parameters – Global from 8.4 

{SitrafficOffice: PDMLogicInstances} TL User parameters – Instances from 8.4 

  

{SitrafficOffice: Assignments} Assignments from 8.1 

 

{SitrafficOffice: ControllerBasicSupply} Basic supply of controller from 8.7 

{SitrafficOffice: TaMethod} Parameters TA method from 8.7 

{SitrafficOffice: TaKernel} Parameters TA kernel from 8.7 

{SitrafficOffice: SignalMonitoring} Signal monitoring from 8.7 
Tab. 1: Overview of the print markings supported by Yutraffic Office. 
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4.2. Headings and table types 

This overview shows the available format types for headings and tables.  

 

 

 

 

 

 

  

  

 

 

 

 

 

 

  

 

4.3. Word fields 

All fields available in the template can be viewed and inserted in the following 
way: Insert -> Quick modules -> Field 
 

 

                                                        Fig. 20: Microsoft Word main window for using quick blocks. 

  

 

The available fields are displayed under Field -> DocProperty and can be 
inserted by double-clicking. 

Font  Description Office Version 

Standard  normal text  from 8.1 

Sitraffic-Heading1  heading 1. Level  from 8.1 

Sitraffic-Heading2  heading 2. Level  from 8.1 

Sitraffic-Heading3  heading 3. Level  from 8.1 

Sitraffic-Heading4  heading 4. Level  from 8.1 

Sitraffic-Legend  legend  from 8.1 

Table style Description Office Version 

Sitraffic-VerticalTable  HBS 2015  from 8.1 

Sitraffic-Matrix  all matrices, e.g. signal group dependencies  from 8.1 

Sitraffic-Table  all table lists, e.g.  signal groups  from 8.1 

Sitraffic-Table-Sp dedicated style for signal programs from 8.7 

Sitraffic-Table-St dedicated style for stage transitions from 8.7 

Tab. 2: Overview of the fonts and table types supported by Yutraffic Office. 
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Fig. 21: Dialog for inserting fields into a document. 

 

  

4.4. Tips & Tricks 
 

4.4.1. Required license 

Docx documentation printing is not available in the demo mode of Yutraffic 
Office. 
 

4.4.2. Word processing program 

The docx format is basically independent of the word processing program 
selected. However, experience has shown that the same *.docx file is 
interpreted differently by different word processing programs (e.g. Open 
Office). Therefore, the correct display and editing of documentation created 
with Yutraffic Office can only be guaranteed for Microsoft Word. 
 

4.4.3. Updating standard print templates 

The standard print templates under C:\Sitraffic\Office\SystemTemplates are 
updated with each new Office version. The respective changes compared to 
the previous version are described in the Office Release Notes. This means 
that user-defined templates can be specifically updated for new Office 
versions. 
 

4.4.4. User-defined templates 

The standard print templates under C:\Sitraffic\Office\SystemTemplates are 
updated with every new Office version. If you have created your own user-
defined templates and these have the name of the standard template (e.g. 
Template_OfficeDocu _EN.docx), these will be overwritten during the 
installation process of the new Office version and will therefore be lost. Please 
give user-defined templates also a user-defined name or save them in a 
different directory. 
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4.4.5. Empty pages 

If an object type (e.g. signal programs) is not selected in step 2 of the print 
dialog, the corresponding object is not inserted in the printout. Depending on 
the template used, this may result in blank pages. Therefore, please select 
the desired objects for the printout using the print markers in the template. 

 

4.4.6. Adapting the display 

For some editors, the display of the respective objects can be customized. 
The selected display is also used for the printout.  
Please note: The selected display is intersection- and user-specific. It is not 
part of the supply data. 

4.4.6.1. Signal programs and stage transitions 

For signal programs and stage transitions (from Office 8.6), the display of the 
signal program can be defined in the color combination editor. This also 
applies to the display of special markings (e.g. GSP, manual hold points etc.) 
or the display of switching points in the tabular section. 

4.4.6.2. Intersection layout and topology 

The new combined layout- and topology editor (from Office 8.7) offers 
numerous options for visualizing various objects (e.g. conflict points, lanes). 
The selected visualization is transferred to the printout. 

 

4.4.7. User Data 

Text documents can be created directly in the Office-application itself:  
intersection version-> User data 
 
These text documents are included in the documentation print under 
{SitrafficOffice: Description} (see chapter 4.1). 
Please note: The use of user data requires the feature-license management 
(file attachments, user data,...). 
 

4.4.8. Auto-Fit for tables 

As of Office 8.7, the width of the tables is automatically adjusted to the 
content of the cells by default. Alternatively, the width of the table can also 
be adjusted to the width of the page. To do this, please replace the value 
“Content” with “Page” in the following file 
c:\Sitraffic\Office\Bin\Sitraffic.Common.PrintingX.json 
  
To activate a change, please restart Office. 

 

4.4.9. Known restrictions 

• Currently, i.e. with Yutraffic Office 8.7, the documentation printout of the 
intergreen time calculation for the Polish- and Swiss guidelines is not 
supported. 

• Supply data was integrated into the documentation print with Office 8.6 and 
optimized for the sX controller family with Office 8.7. There may be 
deviations from the usual formatting for the Cxx and M controller family.
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